UNLV School of Dental Medicine MiPACS not performing as expected

Incident Report for UNLV

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2025 - 10:18 PDT

Identified

UNLV School of Dental Medicine MiPACS software is not performing as expected. Users may experience issues accessing the application.

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi_mipacs
Posted Apr 02, 2025 - 10:16 PDT
This incident affects: Applications.