UNLV multiple building power outage

Incident Report for UNLV

Resolved

This incident has been resolved.
Posted Dec 13, 2025 - 07:20 PST

Identified

Multiple UNLV buildings are experiencing a power-related outage. Users may experience issues with the facility power and the UNLV wired/wireless networks.

Impacted locations:

Academic Success Center (ASC)
Claudine Williams Residence Hall (CWH)
Dayton Complex South (DAYS)
Dayton Complex North (DAYN)
Dining Commons (DIN)
Gym Roads Residence Hall Building B (RHB)
Gym Roads Residence Hall Building C (RHC)
Kitty Rodman Residence Hall (KRH)
Margie and Robert Faiman Residence Hall (MFH)
Mitzi and Johnny Hughes Residence Hall (HUH)
Student Life Maintenance and Technology (SMT)
Tropicana Parking Garage (PKG2)
William S. Boyd Residence Hall (WBH)

--
UNLV Information Technology
IT Help Desk
ithelp@unlv.edu
702-895-0777

#mi-main-campus-south-power-outage
Posted Dec 12, 2025 - 20:21 PST